<!DOCTYPE html><html lang="ru-RU"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="shortcut icon" href="/favicon.ico" type="image/x-icon"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://geekus.ru/xmlrpc.php"> <!--[if lt IE 9]> <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script> <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script> <![endif]--> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script> <!-- This site is optimized with the Yoast SEO plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10...) | Geekus</title><meta name="description" content="Много лет я использовал в Linux клавишу Caps Lock для переключения раскладки. Назначить ее в новых версиях Ubuntu - задача нетривиальная... но решаемая." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/" /><meta property="og:locale" content="ru_RU" /><meta property="og:type" content="article" /><meta property="og:title" content="Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10...) | Geekus" /><meta property="og:description" content="Много лет я использовал в Linux клавишу Caps Lock для переключения раскладки. Назначить ее в новых версиях Ubuntu - задача нетривиальная... но решаемая." /><meta property="og:url" content="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/" /><meta property="og:site_name" content="Geekus" /><meta property="article:publisher" content="https://www.facebook.com/groups/geekus.ru/" /><meta property="article:author" content="https://www.facebook.com/groups/geekus.ru/" /><meta property="article:published_time" content="2019-08-22T17:29:03+00:00" /><meta property="article:modified_time" content="2019-10-26T11:12:10+00:00" /><meta property="og:image" content="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change.jpg" /><meta property="og:image:width" content="350" /><meta property="og:image:height" content="220" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@geekus_ru" /><meta name="twitter:site" content="@geekus_ru" /><meta name="twitter:label1" content="Написано автором"><meta name="twitter:data1" content="zhart"><meta name="twitter:label2" content="Примерное время для чтения"><meta name="twitter:data2" content="0 минут"> <script type="application/ld+json" class="yoast-schema-graph">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</script> <!-- / Yoast SEO plugin. --><link rel='stylesheet' id='fvm-header-0-css'  href='https://geekus.ru/media/cache/fvm/1601541565/out/header-f85c5c5180724e5103e495201c14388d99370d8c.min.css' type='text/css' media='all' /><link rel='stylesheet' id='bootflex-css'  href='https://geekus.ru/content/themes/bootflex-child/style.css' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-2-css'  href='https://geekus.ru/media/cache/fvm/1601541565/out/header-0dea904138e8785734b196fe919c240212a29583.min.css' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://geekus.ru/wp-includes/js/jquery/jquery.js' id='jquery-js'></script><script type='text/javascript' id='fvm-header-0-js-extra'>/*  */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"0","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"1","woocommerce_gallery":"0","ajaxurl":"https:\/\/geekus.ru\/wp-admin\/admin-ajax.php","nonce":"b7a09669fa"};
/*  */</script> <script type='text/javascript' src='https://geekus.ru/media/cache/fvm/1601541565/out/header-53644b9609aca02dafb31ab9fae4cf5aafa09c40.min.js' id='fvm-header-0-js'></script><script type='text/javascript' src='https://geekus.ru/content/themes/bootflex-child/flexslider/jquery.flexslider-min.js' id='flexslider-js-js'></script><script type='text/javascript' id='fvm-header-2-js-extra'>/*  */
var icwp_wpsf_vars_lpantibot = {"form_selectors":"","uniq":"5fa5103287518","cbname":"icwp-wpsf-59a1cb8d6e809","strings":{"label":"\u042f - \u0447\u0435\u043b\u043e\u0432\u0435\u043a.","alert":"\u041f\u043e\u0436\u0430\u043b\u0443\u0439\u0441\u0442\u0430, \u043f\u043e\u0441\u0442\u0430\u0432\u044c\u0442\u0435 \u0433\u0430\u043b\u043e\u0447\u043a\u0443, \u0447\u0442\u043e\u0431\u044b \u043f\u043e\u0434\u0442\u0432\u0435\u0440\u0434\u0438\u0442\u044c, \u0447\u0442\u043e \u0412\u044b - \u0447\u0435\u043b\u043e\u0432\u0435\u043a.","loading":"\u0417\u0430\u0433\u0440\u0443\u0437\u043a\u0430"},"flags":{"gasp":true,"captcha":false}};
/*  */</script> <script type='text/javascript' src='https://geekus.ru/media/cache/fvm/1601541565/out/header-f1af2c47819fd2932113022a1d7672a49fb33119.min.js' id='fvm-header-2-js'></script><link rel="https://api.w.org/" href="https://geekus.ru/wp-json/" /><link rel="alternate" type="application/json" href="https://geekus.ru/wp-json/wp/v2/posts/689" /><link rel="alternate" type="application/json+oembed" href="https://geekus.ru/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" /><link rel="alternate" type="text/xml+oembed" href="https://geekus.ru/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&#038;format=xml" /><!-- GA Google Analytics @ https://m0n.co/ga --> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-105764518-3', 'auto');
			ga('send', 'pageview');</script> <!-- This site uses the Open External Links in a New Window plugin v1.4 by WebFactory Ltd. Download it for free at https://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ --> <script type="text/javascript">//
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = 'geekus.ru';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('geekus.ru') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //</script> <style type="text/css">.bootflextitle{color: ##fff} .bootflexdesc{color: ##fff} body.admin-bar .bootflex-header{position: fixed;top: 32px;height: 100px;background-image: url("https://geekus.ru/media/bg-diagonal-pattern.png");width:100%;z-index: 1040;transition: all 0.4s ease;} body .bootflex-header{position: fixed;top: 0px;height: 100px;background-image: url("https://geekus.ru/media/bg-diagonal-pattern.png");width:100%;z-index: 1040;transition: all 0.4s ease;}</style></head><body data-rsssl=1 class="post-template-default single single-post postid-689 single-format-standard"> <header class="bootflex-header bg-info hidden-print"><div class="container" id="biglogo"><div id="sidebar-header" class="bootflex-header-widget pull-right hidden-sm"><div class="textwidget custom-html-widget"><div class="socialmediaicons"> <a href="/contacts/" class="fa fa-envelope"></a> <a href="https://www.facebook.com/groups/geekus.ru/" class="fa fa-facebook" rel="noopener nofollow noreferrer" target="_blank"></a> <a href="https://twitter.com/geekus_ru" class="fa fa-twitter" rel="noopener nofollow noreferrer" target="_blank"></a> <a href="/feed/" class="fa fa-rss" rel="noopener nofollow noreferrer" target="_blank"></a></div></div></div><div id="logo"> <a href="https://geekus.ru/"> <img src="https://geekus.ru/media/logo.png" srcset="" alt="Geekus" class="bootflex-logo" data-toggle="tooltip" data-placement="bottom" title="Гиковский блог"></a></div></div> </header> <!-- Fixed navbar --> <nav class="navbar navbar-default navbar-fixed-top hidden-print"><div class="container mymain"><div class="navbar-header"> <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button><div id="smalllogo"></div></div><div id="navbar" class="navbar-collapse collapse"><ul id="navbarmenu" class="nav navbar-nav navbar-right"><li id="menu-item-379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-379"><a title="Главная" href="/"><span class="glyphicon glyphicon-home"></span>&nbsp;Главная</a></li><li id="menu-item-382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-382"><a title="Linux" href="https://geekus.ru/linux/"><span class="glyphicon glyphicon-sunglasses"></span>&nbsp;Linux</a></li><li id="menu-item-383" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-383"><a title="Ubuntu" href="https://geekus.ru/ubuntu/"><span class="glyphicon glyphicon-magnet"></span>&nbsp;Ubuntu</a></li><li id="menu-item-385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-385"><a title="Софт" href="https://geekus.ru/software/"><span class="glyphicon glyphicon-cog"></span>&nbsp;Софт</a></li><li id="menu-item-384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384"><a title="Игры" href="https://geekus.ru/games/"><span class="glyphicon glyphicon-knight"></span>&nbsp;Игры</a></li></ul></div></div> </nav><div class="container" role="main"><ol class="breadcrumb"><li><a href="https://geekus.ru"><span class="glyphicon glyphicon-home" aria-hidden="true" title="Главная страница"></span> Главная страница</a></li><li><a href="https://geekus.ru/ubuntu/">Ubuntu</a></li><li class="active">Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10&#8230;)</li></ol><div class="row"><div class="col-md-8 container-primary-content"> <article role="main" id="post-689" class="post-689 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu nc-is-auto-shared"><div class="row"><div class="col-md-12"> <section><h1>Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10&#8230;)</h1><div class="bootflex-info text-muted hidden-print"><ul class="list-inline"><li class="list-group-item" data-toggle="tooltip" data-placement="top" title="Дата публикации"><span class="glyphicon glyphicon-calendar" aria-hidden="true"></span>&nbsp;&nbsp;22.08.2019</li> <!--<li class="list-group-item"><span class="glyphicon glyphicon-user" aria-hidden="true" data-toggle="tooltip" data-placement="top" title="Написано пользователем zhart"></span>&nbsp;&nbsp;<a href="https://geekus.ru/" data-toggle="tooltip" data-placement="top" title="Перейти к zharts вебсайт">zhart</a></li> --> <!--<li class="list-group-item" data-toggle="tooltip" data-placement="top" title="Постоянная ссылка"><span class="glyphicon glyphicon-link" aria-hidden="true"></span>&nbsp;&nbsp;<a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/">Permalink</a></li> --><li class="list-group-item" data-toggle="tooltip" data-placement="top" title="Комментарии"><span class="glyphicon glyphicon-comment" aria-hidden="true"></span>&nbsp;&nbsp;8 комментариев</li><li class="list-group-item" data-toggle="tooltip" data-placement="top" title="Категория"><span class="glyphicon glyphicon-folder-open" aria-hidden="true"></span>&nbsp;&nbsp;<a href="https://geekus.ru/ubuntu/" rel="category tag">Ubuntu</a></li></ul></div><div class="shariff shariff-align-flex-start shariff-widget-align-flex-start" style="display:none" data-services="facebook%7Ctwitter%7Cpinterest%7Codnoklassniki%7Cvk" data-url="https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" data-timestamp="1572099130" data-backendurl="https://geekus.ru/wp-json/shariff/v1/share_counts?"><div class="ShariffHeadline"><p><b>Поделитесь этой страницей с друзьями:</b></p></div><ul class="shariff-buttons theme-round orientation-horizontal buttonsize-medium"><li class="shariff-button facebook shariff-nocustomcolor" style="background-color:#4273c8;border-radius:10%"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" title="Поделиться на Facebook" aria-label="Поделиться на Facebook" role="button" rel="nofollow" class="shariff-link" style=";border-radius:10%; background-color:#3b5998; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 32"><path fill="#3b5998" d="M17.1 0.2v4.7h-2.8q-1.5 0-2.1 0.6t-0.5 1.9v3.4h5.2l-0.7 5.3h-4.5v13.6h-5.5v-13.6h-4.5v-5.3h4.5v-3.9q0-3.3 1.9-5.2t5-1.8q2.6 0 4.1 0.2z"/></svg></span></a></li><li class="shariff-button twitter shariff-nocustomcolor" style="background-color:#32bbf5;border-radius:10%"><a href="https://twitter.com/share?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&text=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Twitter" aria-label="Поделиться на Twitter" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#55acee; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32"><path fill="#55acee" d="M29.7 6.8q-1.2 1.8-3 3.1 0 0.3 0 0.8 0 2.5-0.7 4.9t-2.2 4.7-3.5 4-4.9 2.8-6.1 1q-5.1 0-9.3-2.7 0.6 0.1 1.5 0.1 4.3 0 7.6-2.6-2-0.1-3.5-1.2t-2.2-3q0.6 0.1 1.1 0.1 0.8 0 1.6-0.2-2.1-0.4-3.5-2.1t-1.4-3.9v-0.1q1.3 0.7 2.8 0.8-1.2-0.8-2-2.2t-0.7-2.9q0-1.7 0.8-3.1 2.3 2.8 5.5 4.5t7 1.9q-0.2-0.7-0.2-1.4 0-2.5 1.8-4.3t4.3-1.8q2.7 0 4.5 1.9 2.1-0.4 3.9-1.5-0.7 2.2-2.7 3.4 1.8-0.2 3.5-0.9z"/></svg></span></a></li><li class="shariff-button linkedin shariff-nocustomcolor" style="background-color:#1488bf;border-radius:10%"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&title=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на LinkedIn" aria-label="Поделиться на LinkedIn" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#0077b5; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#0077b5" d="M6.2 11.2v17.7h-5.9v-17.7h5.9zM6.6 5.7q0 1.3-0.9 2.2t-2.4 0.9h0q-1.5 0-2.4-0.9t-0.9-2.2 0.9-2.2 2.4-0.9 2.4 0.9 0.9 2.2zM27.4 18.7v10.1h-5.9v-9.5q0-1.9-0.7-2.9t-2.3-1.1q-1.1 0-1.9 0.6t-1.2 1.5q-0.2 0.5-0.2 1.4v9.9h-5.9q0-7.1 0-11.6t0-5.3l0-0.9h5.9v2.6h0q0.4-0.6 0.7-1t1-0.9 1.6-0.8 2-0.3q3 0 4.9 2t1.9 6z"/></svg></span></a></li><li class="shariff-button pinterest shariff-nocustomcolor" style="background-color:#e70f18;border-radius:10%"><a href="https://www.pinterest.com/pin/create/link/?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&media=https%3A%2F%2Fgeekus.ru%2Fmedia%2Fubuntu-caps-lock-keyboard-layout-change.jpg&description=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Pinterest" aria-label="Поделиться на Pinterest" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#cb2027; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#cb2027" d="M27.4 16q0 3.7-1.8 6.9t-5 5-6.9 1.9q-2 0-3.9-0.6 1.1-1.7 1.4-2.9 0.2-0.6 1-3.8 0.4 0.7 1.3 1.2t2 0.5q2.1 0 3.8-1.2t2.7-3.4 0.9-4.8q0-2-1.1-3.8t-3.1-2.9-4.5-1.2q-1.9 0-3.5 0.5t-2.8 1.4-2 2-1.2 2.3-0.4 2.4q0 1.9 0.7 3.3t2.1 2q0.5 0.2 0.7-0.4 0-0.1 0.1-0.5t0.2-0.5q0.1-0.4-0.2-0.8-0.9-1.1-0.9-2.7 0-2.7 1.9-4.6t4.9-2q2.7 0 4.2 1.5t1.5 3.8q0 3-1.2 5.2t-3.1 2.1q-1.1 0-1.7-0.8t-0.4-1.9q0.1-0.6 0.5-1.7t0.5-1.8 0.2-1.4q0-0.9-0.5-1.5t-1.4-0.6q-1.1 0-1.9 1t-0.8 2.6q0 1.3 0.4 2.2l-1.8 7.5q-0.3 1.2-0.2 3.2-3.7-1.6-6-5t-2.3-7.6q0-3.7 1.9-6.9t5-5 6.9-1.9 6.9 1.9 5 5 1.8 6.9z"/></svg></span></a></li><li class="shariff-button odnoklassniki shariff-nocustomcolor" style="background-color:#f3a752;border-radius:10%"><a href="https://connect.ok.ru/offer?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&title=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Odnoklassniki" aria-label="Поделиться на Odnoklassniki" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#ee8208; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg xmlns="http://www.w3.org/2000/svg" width="14" height="20" viewBox="0 0 14 20"><path fill="#ee8208"  d="M7.1 10.1q-2.1 0-3.6-1.5t-1.5-3.6q0-2.1 1.5-3.6t3.6-1.5 3.6 1.5 1.5 3.6q0 2.1-1.5 3.6t-3.6 1.5zM7.1 2.6q-1 0-1.8 0.7t-0.7 1.8q0 1 0.7 1.8t1.8 0.7 1.8-0.7 0.7-1.8q0-1-0.7-1.8t-1.8-0.7zM13 10.7q0.1 0.3 0.2 0.6t0 0.5-0.3 0.4-0.5 0.4-0.7 0.5q-1.3 0.8-3.5 1l0.8 0.8 3 3q0.3 0.3 0.3 0.8t-0.3 0.8l-0.1 0.1q-0.3 0.3-0.8 0.3t-0.8-0.3q-0.7-0.8-3-3l-3 3q-0.3 0.3-0.8 0.3t-0.8-0.3l-0.1-0.1q-0.3-0.3-0.3-0.8t0.3-0.8l3.8-3.8q-2.3-0.2-3.5-1-0.4-0.3-0.7-0.5t-0.5-0.4-0.3-0.4 0-0.5 0.2-0.6q0.1-0.2 0.3-0.4t0.5-0.2 0.6 0 0.7 0.4q0.1 0 0.2 0.1t0.5 0.3 0.8 0.3 1 0.3 1.3 0.1q1 0 1.9-0.3t1.3-0.6l0.4-0.3q0.4-0.3 0.7-0.4t0.6 0 0.5 0.2 0.3 0.4z"/></svg></span></a></li><li class="shariff-button vk shariff-nocustomcolor" style="background-color:#4273c8;border-radius:10%"><a href="https://vk.com/share.php?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" title="Поделиться на ВКонтакте" aria-label="Поделиться на ВКонтакте" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#527498; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 34 32"><path fill="#527498" d="M34.2 9.3q0.4 1.1-2.7 5.3-0.4 0.6-1.2 1.5-1.4 1.8-1.6 2.3-0.3 0.7 0.3 1.4 0.3 0.4 1.4 1.5h0l0.1 0.1q2.5 2.3 3.4 3.9 0.1 0.1 0.1 0.2t0.1 0.5 0 0.6-0.4 0.5-1.1 0.2l-4.6 0.1q-0.4 0.1-1-0.1t-0.9-0.4l-0.4-0.2q-0.5-0.4-1.2-1.1t-1.2-1.4-1.1-1-1-0.3q-0.1 0-0.1 0.1t-0.3 0.3-0.4 0.5-0.3 0.9-0.1 1.4q0 0.3-0.1 0.5t-0.1 0.3l-0.1 0.1q-0.3 0.3-0.9 0.4h-2.1q-1.3 0.1-2.6-0.3t-2.3-0.9-1.8-1.2-1.3-1l-0.4-0.4q-0.2-0.2-0.5-0.5t-1.3-1.6-1.9-2.7-2.2-3.8-2.3-4.9q-0.1-0.3-0.1-0.5t0.1-0.3l0.1-0.1q0.3-0.3 1-0.3l4.9 0q0.2 0 0.4 0.1t0.3 0.2l0.1 0.1q0.3 0.2 0.4 0.6 0.4 0.9 0.8 1.8t0.7 1.5l0.3 0.5q0.5 1.1 1 1.9t0.9 1.2 0.7 0.7 0.6 0.3 0.5-0.1q0 0 0.1-0.1t0.2-0.4 0.2-0.8 0.2-1.4 0-2.2q0-0.7-0.2-1.3t-0.2-0.8l-0.1-0.2q-0.4-0.6-1.5-0.8-0.2 0 0.1-0.4 0.3-0.3 0.7-0.5 0.9-0.5 4.3-0.4 1.5 0 2.4 0.2 0.4 0.1 0.6 0.2t0.4 0.4 0.2 0.6 0.1 0.8 0 1 0 1.3 0 1.5q0 0.2 0 0.8t0 0.9 0.1 0.7 0.2 0.7 0.4 0.4q0.1 0 0.3 0.1t0.5-0.2 0.7-0.6 0.9-1.2 1.2-1.9q1.1-1.9 1.9-4 0.1-0.2 0.2-0.3t0.2-0.2l0.1-0.1 0.1 0t0.2-0.1 0.4 0l5.1 0q0.7-0.1 1.1 0t0.6 0.3z"/></svg></span></a></li></ul></div><div class="post-body"> <section class="content-section"><div class="row"><div class="col-lg-8 col-md-8 col-sm-8 col-xs-12"><p>Много лет я использовал в Linux клавишу <kbd>Caps Lock</kbd> для переключения раскладки. И с этим не было проблем, пока я не решил обновиться до новой Ubuntu 19.04, заодно <a href="/budgie-as-unity-replacement/" title="">сменив дефолтную оболочку</a>. Здесь назначить <kbd>Caps Lock</kbd> – задача нетривиальная. Насколько я знаю, в Ubuntu 18.04 – тоже. То есть статья пригодится пользователям Ubuntu 18.04 и новее.</p></div><div class="col-lg-4 col-md-4 col-sm-4 col-xs-12"> <figure class="intro-image img-thumbnail"><img width="350" height="220" src="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-350x220.jpg" class="attachment-medium size-medium wp-post-image" alt="Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04...)" loading="lazy"></figure></div></div> </section><div class="ga-post-a-resp"><div id="custom_html-6" class="widget_text ga-post-resp widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="altcon2"></div> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-format="fluid" data-ad-layout="in-article" data-ad-client="ca-pub-5168781927663874" data-ad-slot="9291691736"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></div><section><div class="simple-block simple-block-skip"><p>Я использую в качестве графической оболочки Budgie, но в Gnome Shell наблюдается та же проблема. Вообще, настройки горячих клавиш в обоих системах одинаковые, даже диалоговое окно используется одно и то же, так что статья актуальна для обоих оболочек.</p><p>Первая мысль – попробовать использовать для смены стандартное диалоговое окно.</p> <figure><a href="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-01.jpg" data-rel="lightbox"><img src="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-01-740x624.jpg" alt="Смена раскладки в диалоговом окне Ubuntu" class="img-thumbnail"></a></figure></div><div class="simple-block simple-block-skip"><p>К сожалению, здесь ничего не выходит. Ну да ничего, мы ведь знаем о существовании “dconf-editor”. Если он не установлен, то это можно исправить командой в консоли:</p><pre>
sudo apt install dconf-editor
</pre><p>Запускаем программу после установки и переходим в раздел <mark>/ org / gnome / desktop / wm / keybindings</mark>, в котором задаем нужные значения для параметров <mark>switch-input-source</mark> и <mark>switch-input-source-backward</mark>:</p> <figure><a href="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-02.jpg" data-rel="lightbox"><img src="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-02-740x440.jpg" alt="Смена раскладки в dconf-editor" class="img-thumbnail"></a></figure></div><div class="simple-block simple-block-skip"><p>Как видно на скриншоте выше, я задал этим двум параметрам соответственно следующие значения:</p><pre>['Caps_Lock', '&lt;Super&gt;space', 'XF86Keyboard']</pre><p>…и</p><pre>['&lt;Shift&gt;Caps_Lock', '&lt;Shift&gt;&lt;Super&gt;space', '&lt;Shift&gt;XF86Keyboard']</pre><p>Я приписал новые значения к дефолтным, но вы можете оставить только новые, удалив дефолтные, то есть так:</p><pre>['Caps_Lock']</pre><p>…и так:</p><pre>['&lt;Shift&gt;Caps_Lock']</pre><p>И даже в стандартном диалоговом окне теперь отображаются правильные комбинации:</p> <figure><a href="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-03.jpg" data-rel="lightbox"><img src="https://geekus.ru/media/ubuntu-caps-lock-keyboard-layout-change-03-740x624.jpg" alt="Индикация раскладки в окне Ubuntu" class="img-thumbnail"></a></figure></div><div class="simple-block simple-block-first"><p>Казалось бы, все должно быть хорошо, но нет. Вернее, переключение раскладки теперь работает, с этим все в порядке. Но одновременно, вместе с ним продолжает работать непосредственный функционал клавиши <kbd>Caps Lock</kbd>, то есть перевод символов в верхний регистр. Естественно, такое положение вещей нас не устраивает, будем исправлять.</p><p>Как это можно исправить? Есть варианты отключения клавиши <kbd>Caps Lock</kbd> или ее переназначение на другие клавиши, но эти варианты нас не устраивают, поскольку тогда наши комбинации для переключения раскладки вообще перестанут работать. Поэтому нужно постараться отключить функционал перевода в верхний регистр, при этом не отключая и не переназначая саму клавишу. Шел я к этому решению сквозь дебри англоязычных форумов и мануалов довольно долго, но в конце концов решение было найдено. Причем не в мануалах, а проверенным “методом тыка”. Поможет нам консольная утилита “xmodmap” (вроде установлена в Ubuntu по дефолту, но если у вас ее нет – установите).</p><p>Итак, волшебная команда в консоли, которая делает то, что нам нужно (то есть отключает функционал капслока, при этом не отключая саму клавишу):</p><pre>
xmodmap -e 'keycode  66 = NoSymbol Caps_Lock'
</pre><p>Естественно, если вы просто введете эту команду в консоли, то она будет работать ровно до перезагрузки. Чтобы она работала всегда – нужно добавить ее в автозагрузку. Сделать это можно разными способами, я выбрал способ добавления этой строки в файл “.profile” в корне домашней папки пользователя (если такого файла нет – создайте его).</p><p>Собственно, на этом все. Надеюсь, эта заметка сильно сэкономит кому-то время на поиск решения.</p></div><div class="panel panel-warning"><div class="panel-heading">Update (октябрь 2019):</div><div class="panel-body"><div class="simple-block"><p>Время идет, а проблема остается. В Ubuntu 19.10 все еще актуальны те же инструкции.</p></div></div></div></section></div><div class="shariff shariff-align-flex-start shariff-widget-align-flex-start" style="display:none" data-services="facebook%7Ctwitter%7Cpinterest%7Codnoklassniki%7Cvk" data-url="https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" data-timestamp="1572099130" data-backendurl="https://geekus.ru/wp-json/shariff/v1/share_counts?"><div class="ShariffHeadline"><hr /><p><b>Понравилась статья? Поделитесь ссылкой с друзьями:</b></p></div><ul class="shariff-buttons theme-round orientation-horizontal buttonsize-medium"><li class="shariff-button facebook shariff-nocustomcolor" style="background-color:#4273c8;border-radius:10%"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" title="Поделиться на Facebook" aria-label="Поделиться на Facebook" role="button" rel="nofollow" class="shariff-link" style=";border-radius:10%; background-color:#3b5998; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 32"><path fill="#3b5998" d="M17.1 0.2v4.7h-2.8q-1.5 0-2.1 0.6t-0.5 1.9v3.4h5.2l-0.7 5.3h-4.5v13.6h-5.5v-13.6h-4.5v-5.3h4.5v-3.9q0-3.3 1.9-5.2t5-1.8q2.6 0 4.1 0.2z"/></svg></span></a></li><li class="shariff-button twitter shariff-nocustomcolor" style="background-color:#32bbf5;border-radius:10%"><a href="https://twitter.com/share?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&text=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Twitter" aria-label="Поделиться на Twitter" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#55acee; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32"><path fill="#55acee" d="M29.7 6.8q-1.2 1.8-3 3.1 0 0.3 0 0.8 0 2.5-0.7 4.9t-2.2 4.7-3.5 4-4.9 2.8-6.1 1q-5.1 0-9.3-2.7 0.6 0.1 1.5 0.1 4.3 0 7.6-2.6-2-0.1-3.5-1.2t-2.2-3q0.6 0.1 1.1 0.1 0.8 0 1.6-0.2-2.1-0.4-3.5-2.1t-1.4-3.9v-0.1q1.3 0.7 2.8 0.8-1.2-0.8-2-2.2t-0.7-2.9q0-1.7 0.8-3.1 2.3 2.8 5.5 4.5t7 1.9q-0.2-0.7-0.2-1.4 0-2.5 1.8-4.3t4.3-1.8q2.7 0 4.5 1.9 2.1-0.4 3.9-1.5-0.7 2.2-2.7 3.4 1.8-0.2 3.5-0.9z"/></svg></span></a></li><li class="shariff-button linkedin shariff-nocustomcolor" style="background-color:#1488bf;border-radius:10%"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&title=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на LinkedIn" aria-label="Поделиться на LinkedIn" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#0077b5; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#0077b5" d="M6.2 11.2v17.7h-5.9v-17.7h5.9zM6.6 5.7q0 1.3-0.9 2.2t-2.4 0.9h0q-1.5 0-2.4-0.9t-0.9-2.2 0.9-2.2 2.4-0.9 2.4 0.9 0.9 2.2zM27.4 18.7v10.1h-5.9v-9.5q0-1.9-0.7-2.9t-2.3-1.1q-1.1 0-1.9 0.6t-1.2 1.5q-0.2 0.5-0.2 1.4v9.9h-5.9q0-7.1 0-11.6t0-5.3l0-0.9h5.9v2.6h0q0.4-0.6 0.7-1t1-0.9 1.6-0.8 2-0.3q3 0 4.9 2t1.9 6z"/></svg></span></a></li><li class="shariff-button pinterest shariff-nocustomcolor" style="background-color:#e70f18;border-radius:10%"><a href="https://www.pinterest.com/pin/create/link/?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&media=https%3A%2F%2Fgeekus.ru%2Fmedia%2Fubuntu-caps-lock-keyboard-layout-change.jpg&description=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Pinterest" aria-label="Поделиться на Pinterest" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#cb2027; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#cb2027" d="M27.4 16q0 3.7-1.8 6.9t-5 5-6.9 1.9q-2 0-3.9-0.6 1.1-1.7 1.4-2.9 0.2-0.6 1-3.8 0.4 0.7 1.3 1.2t2 0.5q2.1 0 3.8-1.2t2.7-3.4 0.9-4.8q0-2-1.1-3.8t-3.1-2.9-4.5-1.2q-1.9 0-3.5 0.5t-2.8 1.4-2 2-1.2 2.3-0.4 2.4q0 1.9 0.7 3.3t2.1 2q0.5 0.2 0.7-0.4 0-0.1 0.1-0.5t0.2-0.5q0.1-0.4-0.2-0.8-0.9-1.1-0.9-2.7 0-2.7 1.9-4.6t4.9-2q2.7 0 4.2 1.5t1.5 3.8q0 3-1.2 5.2t-3.1 2.1q-1.1 0-1.7-0.8t-0.4-1.9q0.1-0.6 0.5-1.7t0.5-1.8 0.2-1.4q0-0.9-0.5-1.5t-1.4-0.6q-1.1 0-1.9 1t-0.8 2.6q0 1.3 0.4 2.2l-1.8 7.5q-0.3 1.2-0.2 3.2-3.7-1.6-6-5t-2.3-7.6q0-3.7 1.9-6.9t5-5 6.9-1.9 6.9 1.9 5 5 1.8 6.9z"/></svg></span></a></li><li class="shariff-button odnoklassniki shariff-nocustomcolor" style="background-color:#f3a752;border-radius:10%"><a href="https://connect.ok.ru/offer?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F&title=%D0%9F%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5%20%D1%8F%D0%B7%D1%8B%D0%BA%D0%BE%D0%B2%D0%BE%D0%B9%20%D1%80%D0%B0%D1%81%D0%BA%D0%BB%D0%B0%D0%B4%D0%BA%D0%B8%20%D0%BF%D0%BE%20Caps%20Lock%20%D0%B2%20%D0%BD%D0%BE%D0%B2%D1%8B%D1%85%20%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D1%8F%D1%85%20Ubuntu%20%2818.04%2C%2018.10%2C%2019.04%2C%2019.10...%29%20%7C%20Geekus" title="Поделиться на Odnoklassniki" aria-label="Поделиться на Odnoklassniki" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#ee8208; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg xmlns="http://www.w3.org/2000/svg" width="14" height="20" viewBox="0 0 14 20"><path fill="#ee8208"  d="M7.1 10.1q-2.1 0-3.6-1.5t-1.5-3.6q0-2.1 1.5-3.6t3.6-1.5 3.6 1.5 1.5 3.6q0 2.1-1.5 3.6t-3.6 1.5zM7.1 2.6q-1 0-1.8 0.7t-0.7 1.8q0 1 0.7 1.8t1.8 0.7 1.8-0.7 0.7-1.8q0-1-0.7-1.8t-1.8-0.7zM13 10.7q0.1 0.3 0.2 0.6t0 0.5-0.3 0.4-0.5 0.4-0.7 0.5q-1.3 0.8-3.5 1l0.8 0.8 3 3q0.3 0.3 0.3 0.8t-0.3 0.8l-0.1 0.1q-0.3 0.3-0.8 0.3t-0.8-0.3q-0.7-0.8-3-3l-3 3q-0.3 0.3-0.8 0.3t-0.8-0.3l-0.1-0.1q-0.3-0.3-0.3-0.8t0.3-0.8l3.8-3.8q-2.3-0.2-3.5-1-0.4-0.3-0.7-0.5t-0.5-0.4-0.3-0.4 0-0.5 0.2-0.6q0.1-0.2 0.3-0.4t0.5-0.2 0.6 0 0.7 0.4q0.1 0 0.2 0.1t0.5 0.3 0.8 0.3 1 0.3 1.3 0.1q1 0 1.9-0.3t1.3-0.6l0.4-0.3q0.4-0.3 0.7-0.4t0.6 0 0.5 0.2 0.3 0.4z"/></svg></span></a></li><li class="shariff-button vk shariff-nocustomcolor" style="background-color:#4273c8;border-radius:10%"><a href="https://vk.com/share.php?url=https%3A%2F%2Fgeekus.ru%2Fubuntu-caps-lock-keyboard-layout-change%2F" title="Поделиться на ВКонтакте" aria-label="Поделиться на ВКонтакте" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#527498; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 34 32"><path fill="#527498" d="M34.2 9.3q0.4 1.1-2.7 5.3-0.4 0.6-1.2 1.5-1.4 1.8-1.6 2.3-0.3 0.7 0.3 1.4 0.3 0.4 1.4 1.5h0l0.1 0.1q2.5 2.3 3.4 3.9 0.1 0.1 0.1 0.2t0.1 0.5 0 0.6-0.4 0.5-1.1 0.2l-4.6 0.1q-0.4 0.1-1-0.1t-0.9-0.4l-0.4-0.2q-0.5-0.4-1.2-1.1t-1.2-1.4-1.1-1-1-0.3q-0.1 0-0.1 0.1t-0.3 0.3-0.4 0.5-0.3 0.9-0.1 1.4q0 0.3-0.1 0.5t-0.1 0.3l-0.1 0.1q-0.3 0.3-0.9 0.4h-2.1q-1.3 0.1-2.6-0.3t-2.3-0.9-1.8-1.2-1.3-1l-0.4-0.4q-0.2-0.2-0.5-0.5t-1.3-1.6-1.9-2.7-2.2-3.8-2.3-4.9q-0.1-0.3-0.1-0.5t0.1-0.3l0.1-0.1q0.3-0.3 1-0.3l4.9 0q0.2 0 0.4 0.1t0.3 0.2l0.1 0.1q0.3 0.2 0.4 0.6 0.4 0.9 0.8 1.8t0.7 1.5l0.3 0.5q0.5 1.1 1 1.9t0.9 1.2 0.7 0.7 0.6 0.3 0.5-0.1q0 0 0.1-0.1t0.2-0.4 0.2-0.8 0.2-1.4 0-2.2q0-0.7-0.2-1.3t-0.2-0.8l-0.1-0.2q-0.4-0.6-1.5-0.8-0.2 0 0.1-0.4 0.3-0.3 0.7-0.5 0.9-0.5 4.3-0.4 1.5 0 2.4 0.2 0.4 0.1 0.6 0.2t0.4 0.4 0.2 0.6 0.1 0.8 0 1 0 1.3 0 1.5q0 0.2 0 0.8t0 0.9 0.1 0.7 0.2 0.7 0.4 0.4q0.1 0 0.3 0.1t0.5-0.2 0.7-0.6 0.9-1.2 1.2-1.9q1.1-1.9 1.9-4 0.1-0.2 0.2-0.3t0.2-0.2l0.1-0.1 0.1 0t0.2-0.1 0.4 0l5.1 0q0.7-0.1 1.1 0t0.6 0.3z"/></svg></span></a></li></ul></div><hr /><nav class="hidden-print"><ul class="pager"><li class="previous"> <a href="https://geekus.ru/albert-launcher/" rel="prev"><span class="glyphicon glyphicon-chevron-left" aria-hidden="true"></span> Albert &#8211; отличный лаунчер для Ubuntu</a></li><li class="next"> <a href="https://geekus.ru/linux-files-encryption/" rel="next">Быстрое шифрование файлов в Linux и синхронизация их через Dropbox <span class="glyphicon glyphicon-chevron-right" aria-hidden="true"></span></a></li></ul> </nav><div class="crp_related "><h4>Похожие статьи:</h4><ul><li><a href="https://geekus.ru/ubuntu-unity-tweak/"    ><img  width="150" height="150"  src="https://geekus.ru/media/ubuntu-unity-tweak-150x150.png" class="crp_thumb crp_featured" alt="Настройка Unity в Ubuntu" title="Настройка Unity в Ubuntu" /><span class="crp_title">Настройка Unity в Ubuntu</span></a></li><li><a href="https://geekus.ru/getdeb-repository-for-ubuntu/"    ><img  width="150" height="150"  src="https://geekus.ru/media/getdeb-repository-for-ubuntu-150x150.png" class="crp_thumb crp_featured" alt="Дополнительные репозитории для Ubuntu Linux от GetDeb" title="Дополнительные репозитории для Ubuntu Linux от GetDeb" /><span class="crp_title">Дополнительные репозитории для Ubuntu Linux от GetDeb</span></a></li><li><a href="https://geekus.ru/install-new-software-in-ubuntu/"    ><img  width="150" height="150"  src="https://geekus.ru/media/install-new-software-in-ubuntu-150x150.png" class="crp_thumb crp_featured" alt="Четыре способа установки программ в Ubuntu Linux" title="Четыре способа установки программ в Ubuntu Linux" /><span class="crp_title">Четыре способа установки программ в Ubuntu Linux</span></a></li><li><a href="https://geekus.ru/linux-games-steam-top/"    ><img  width="150" height="150"  src="https://geekus.ru/media/linux-games-steam-top-150x150.png" class="crp_thumb crp_featured" alt="200 лучших игр для Linux в Steam" title="200 лучших игр для Linux в Steam" /><span class="crp_title">200 лучших игр для Linux в Steam</span></a></li></ul><div class="crp_clear"></div></div><div class="heateor_sc_social_comments"><div style="clear:both"></div><h3 class="comment-reply-title">Оставить комментарий</h3><div style="clear:both"></div><ul class="heateor_sc_comments_tabs"><li><a class="heateor-sc-ui-tabs-active" id="heateor_sc_wordpress_comments_a" href="javascript:void(0)" onclick="this.setAttribute('class', 'heateor-sc-ui-tabs-active');document.getElementById('heateor_sc_wordpress_comments').style.display = 'block';document.getElementById('heateor_sc_disqus_comments_a').setAttribute('class', '');document.getElementById('heateor_sc_disqus_comments').style.display = 'none';"><div title="Локальные комментарии" class="heateor_sc_wordpress_background"><i class="heateor_sc_wordpress_svg"></i></div><span class="heateor_sc_comments_label">Локальные комментарии</span> (8)</a></li><li><a  id="heateor_sc_disqus_comments_a" href="javascript:void(0)" onclick="this.setAttribute('class', 'heateor-sc-ui-tabs-active');document.getElementById('heateor_sc_disqus_comments').style.display = 'block';document.getElementById('heateor_sc_wordpress_comments_a').setAttribute('class', '');document.getElementById('heateor_sc_wordpress_comments').style.display = 'none';"><div title="Disqus комментарии" class="heateor_sc_disqus_background"><i class="heateor_sc_disqus_svg"></i></div><span class="heateor_sc_comments_label">Disqus комментарии</span> (0)</a></li></ul><div  id="heateor_sc_wordpress_comments"><div style="clear:both"></div> <!-- You can start editing here. --><h3 id="comments"> 8 комментариев на &laquo;&#8220;Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10&#8230;)&#8221;&raquo;</h3><div class="navigation"><div class="alignleft"></div><div class="alignright"></div></div><ol class="commentlist"><li id="comment-505" class="comment even thread-even depth-1"> <article id="div-comment-505" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/52c3873d836588dccca3a453ce6b469c?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/52c3873d836588dccca3a453ce6b469c?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn">MadArcher</b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-505"> <time datetime="2019-09-13T14:17:40+03:00"> 13.09.2019 в 14:17 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>Супер! Именно этого не хватало!</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-505' data-commentid="505" data-postid="689" data-belowelement="div-comment-505" data-respondelement="respond" data-replyto="Комментарий к записи MadArcher" aria-label='Комментарий к записи MadArcher'>Ответить</a></div> </article><!-- .comment-body --></li><!-- #comment-## --><li id="comment-515" class="comment odd alt thread-odd thread-alt depth-1 parent"> <article id="div-comment-515" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/745ea83e7616f1130ae15ea1c8fbc8f7?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/745ea83e7616f1130ae15ea1c8fbc8f7?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn"><a href='https://ubuntu-news.ru/' rel='external nofollow ugc' class='url'>ram32</a></b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-515"> <time datetime="2020-04-23T15:48:25+03:00"> 23.04.2020 в 15:48 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>Отлично!<br /> А еще можно использовать gnome-tweaks, там в параметрах клавиатуры есть настройка раскладки.</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-515' data-commentid="515" data-postid="689" data-belowelement="div-comment-515" data-respondelement="respond" data-replyto="Комментарий к записи ram32" aria-label='Комментарий к записи ram32'>Ответить</a></div> </article><!-- .comment-body --><ul class="children"><li id="comment-516" class="comment even depth-2"> <article id="div-comment-516" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/47f2bda7d950c1a9e8a07edaaab756d7?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/47f2bda7d950c1a9e8a07edaaab756d7?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn">Александр</b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-516"> <time datetime="2020-04-28T11:52:52+03:00"> 28.04.2020 в 11:52 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>это лучшее решение! Спасибо)))</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-516' data-commentid="516" data-postid="689" data-belowelement="div-comment-516" data-respondelement="respond" data-replyto="Комментарий к записи Александр" aria-label='Комментарий к записи Александр'>Ответить</a></div> </article><!-- .comment-body --></li><!-- #comment-## --><li id="comment-518" class="comment byuser comment-author-zhart bypostauthor odd alt depth-2 parent"> <article id="div-comment-518" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn"><a href='https://geekus.ru/' rel='external nofollow ugc' class='url'>zhart</a></b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-518"> <time datetime="2020-05-12T09:43:44+03:00"> 12.05.2020 в 09:43 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>А это правда у кого-то работает в Budgie?<br /> У меня и в 19.10 изменение параметров клавиатуры ни на что не влияли (что в разделе изменения раскладки, что в разделе изменения поведения  Caps Lock), и в 20.04 то же самое. Специально заглянул — у меня там перманентно галочки нужные стоят, только толку ноль от них.</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-518' data-commentid="518" data-postid="689" data-belowelement="div-comment-518" data-respondelement="respond" data-replyto="Комментарий к записи zhart" aria-label='Комментарий к записи zhart'>Ответить</a></div> </article><!-- .comment-body --><ul class="children"><li id="comment-521" class="comment even depth-3 parent"> <article id="div-comment-521" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/e2eb2a78a67a1736e656f716f2cb5e65?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/e2eb2a78a67a1736e656f716f2cb5e65?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn"><a href='https://batazor.ru' rel='external nofollow ugc' class='url'>batazor</a></b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-521"> <time datetime="2020-06-07T00:06:31+03:00"> 07.06.2020 в 00:06 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>Да, у меня все отлично заработало.</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-521' data-commentid="521" data-postid="689" data-belowelement="div-comment-521" data-respondelement="respond" data-replyto="Комментарий к записи batazor" aria-label='Комментарий к записи batazor'>Ответить</a></div> </article><!-- .comment-body --><ul class="children"><li id="comment-522" class="comment byuser comment-author-zhart bypostauthor odd alt depth-4"> <article id="div-comment-522" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn"><a href='https://geekus.ru/' rel='external nofollow ugc' class='url'>zhart</a></b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-522"> <time datetime="2020-06-07T20:40:34+03:00"> 07.06.2020 в 20:40 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>В Budgie, или в дефолтном Gnome Shell?</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-522' data-commentid="522" data-postid="689" data-belowelement="div-comment-522" data-respondelement="respond" data-replyto="Комментарий к записи zhart" aria-label='Комментарий к записи zhart'>Ответить</a></div> </article><!-- .comment-body --></li><!-- #comment-## --></ul><!-- .children --></li><!-- #comment-## --></ul><!-- .children --></li><!-- #comment-## --></ul><!-- .children --></li><!-- #comment-## --><li id="comment-537" class="comment even thread-even depth-1 parent"> <article id="div-comment-537" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/621c629dc52173f5c024683fc8d079a2?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/621c629dc52173f5c024683fc8d079a2?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn">Александра</b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-537"> <time datetime="2020-09-29T12:50:43+03:00"> 29.09.2020 в 12:50 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>Автор статьи, спасибо тебе огромное! Твои инструкции очень помогли мне настроить всё так, как мне нужно.</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-537' data-commentid="537" data-postid="689" data-belowelement="div-comment-537" data-respondelement="respond" data-replyto="Комментарий к записи Александра" aria-label='Комментарий к записи Александра'>Ответить</a></div> </article><!-- .comment-body --><ul class="children"><li id="comment-538" class="comment byuser comment-author-zhart bypostauthor odd alt depth-2"> <article id="div-comment-538" class="comment-body"> <footer class="comment-meta"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=32&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/ab6e923883decd22175289c2a34f8bf3?s=64&#038;d=wavatar&#038;r=g 2x' class='avatar img-rounded avatar-32 photo' height='32' width='32' loading='lazy'/> <b class="fn"><a href='https://geekus.ru/' rel='external nofollow ugc' class='url'>zhart</a></b><span class="says">:</span></div><!-- .comment-author --><div class="comment-metadata"> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/#comment-538"> <time datetime="2020-09-29T16:05:19+03:00"> 29.09.2020 в 16:05 </time> </a></div><!-- .comment-metadata --></footer><!-- .comment-meta --><div class="comment-content"><p>Александра, пожалуйста. Рад, что смог помочь)</p></div><!-- .comment-content --><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-538' data-commentid="538" data-postid="689" data-belowelement="div-comment-538" data-respondelement="respond" data-replyto="Комментарий к записи zhart" aria-label='Комментарий к записи zhart'>Ответить</a></div> </article><!-- .comment-body --></li><!-- #comment-## --></ul><!-- .children --></li><!-- #comment-## --></ol><div class="navigation"><div class="alignleft"></div><div class="alignright"></div></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Добавить комментарий <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ubuntu-caps-lock-keyboard-layout-change/#respond" style="display:none;">Отменить ответ</a></small></h3><form action="https://geekus.ru/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Ваш адрес email не будет опубликован.</span> Обязательные поля помечены <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Комментарий</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Имя <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Сайт</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Отправить комментарий" /> <input type='hidden' name='comment_post_ID' value='689' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p id="rRbMy9awWN6t25fYpZ3KmEK7"></p></form></div><!-- #respond --><div style="clear:both"></div></div><div style="display:none" id="heateor_sc_disqus_comments"><div class="embed-container clearfix" id="disqus_thread">geekus</div><script type="text/javascript">var disqus_shortname = "geekus";(function(d) {var dsq = d.createElement("script"); dsq.type = "text/javascript"; dsq.async = true;dsq.src = "//" + disqus_shortname + ".disqus.com/embed.js"; (d.getElementsByTagName("head")[0] || d.getElementsByTagName("body")[0]).appendChild(dsq); })(document);</script></div></div> </section></div></div> </article></div><div role="complementary" class="col-md-4 hidden-print container-sidebar"> <section> <aside class="well widget widget_search"><form role="form" method="get" action="https://geekus.ru/"> <label for="s"> <span class="sr-only">Искать:</span> </label><div class="input-group"> <input type="search" class="form-control" placeholder="Поиск…" value="" name="s" id="s" title="Искать:" /> <span class="input-group-btn"> <button class="btn btn-default" type="submit" title="Поиск" data-toggle="tooltip" data-placement="bottom"><span class="glyphicon glyphicon-search" aria-hidden="true"></span></button> </span></div></form></aside><aside class="well widget Shariff"><h3>Расскажите об этом сайте друзьям:</h3><div class="shariff shariff-align-flex-start shariff-widget-align-flex-start" style="display:none" data-services="facebook%7Ctwitter%7Cpinterest%7Codnoklassniki%7Cvk" data-url="http%3A%2F%2Fgeekus.ru" data-timestamp="1572099130" data-backendurl="https://geekus.ru/wp-json/shariff/v1/share_counts?"><ul class="shariff-buttons theme-round orientation-horizontal buttonsize-medium"><li class="shariff-button facebook" style="background-color:#dd4814;border-radius:10%"><a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fgeekus.ru" title="Поделиться на Facebook" aria-label="Поделиться на Facebook" role="button" rel="nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 32"><path fill="#3b5998" d="M17.1 0.2v4.7h-2.8q-1.5 0-2.1 0.6t-0.5 1.9v3.4h5.2l-0.7 5.3h-4.5v13.6h-5.5v-13.6h-4.5v-5.3h4.5v-3.9q0-3.3 1.9-5.2t5-1.8q2.6 0 4.1 0.2z"/></svg></span></a></li><li class="shariff-button twitter" style="background-color:#dd4814;border-radius:10%"><a href="https://twitter.com/share?url=http%3A%2F%2Fgeekus.ru&text=%D0%93%D0%B8%D0%BA%D0%BE%D0%B2%D1%81%D0%BA%D0%B8%D0%B9%20%D0%B1%D0%BB%D0%BE%D0%B3%20Geekus.ru" title="Поделиться на Twitter" aria-label="Поделиться на Twitter" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32"><path fill="#55acee" d="M29.7 6.8q-1.2 1.8-3 3.1 0 0.3 0 0.8 0 2.5-0.7 4.9t-2.2 4.7-3.5 4-4.9 2.8-6.1 1q-5.1 0-9.3-2.7 0.6 0.1 1.5 0.1 4.3 0 7.6-2.6-2-0.1-3.5-1.2t-2.2-3q0.6 0.1 1.1 0.1 0.8 0 1.6-0.2-2.1-0.4-3.5-2.1t-1.4-3.9v-0.1q1.3 0.7 2.8 0.8-1.2-0.8-2-2.2t-0.7-2.9q0-1.7 0.8-3.1 2.3 2.8 5.5 4.5t7 1.9q-0.2-0.7-0.2-1.4 0-2.5 1.8-4.3t4.3-1.8q2.7 0 4.5 1.9 2.1-0.4 3.9-1.5-0.7 2.2-2.7 3.4 1.8-0.2 3.5-0.9z"/></svg></span></a></li><li class="shariff-button linkedin" style="background-color:#dd4814;border-radius:10%"><a href="https://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fgeekus.ru&title=%D0%93%D0%B8%D0%BA%D0%BE%D0%B2%D1%81%D0%BA%D0%B8%D0%B9%20%D0%B1%D0%BB%D0%BE%D0%B3%20Geekus.ru" title="Поделиться на LinkedIn" aria-label="Поделиться на LinkedIn" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#0077b5" d="M6.2 11.2v17.7h-5.9v-17.7h5.9zM6.6 5.7q0 1.3-0.9 2.2t-2.4 0.9h0q-1.5 0-2.4-0.9t-0.9-2.2 0.9-2.2 2.4-0.9 2.4 0.9 0.9 2.2zM27.4 18.7v10.1h-5.9v-9.5q0-1.9-0.7-2.9t-2.3-1.1q-1.1 0-1.9 0.6t-1.2 1.5q-0.2 0.5-0.2 1.4v9.9h-5.9q0-7.1 0-11.6t0-5.3l0-0.9h5.9v2.6h0q0.4-0.6 0.7-1t1-0.9 1.6-0.8 2-0.3q3 0 4.9 2t1.9 6z"/></svg></span></a></li><li class="shariff-button pinterest" style="background-color:#dd4814;border-radius:10%"><a href="https://www.pinterest.com/pin/create/link/?url=http%3A%2F%2Fgeekus.ru&media=https%3A%2F%2Fgeekus.ru%2Fmedia%2Fubuntu-caps-lock-keyboard-layout-change.jpg&description=%D0%93%D0%B8%D0%BA%D0%BE%D0%B2%D1%81%D0%BA%D0%B8%D0%B9%20%D0%B1%D0%BB%D0%BE%D0%B3%20Geekus.ru" title="Поделиться на Pinterest" aria-label="Поделиться на Pinterest" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path fill="#cb2027" d="M27.4 16q0 3.7-1.8 6.9t-5 5-6.9 1.9q-2 0-3.9-0.6 1.1-1.7 1.4-2.9 0.2-0.6 1-3.8 0.4 0.7 1.3 1.2t2 0.5q2.1 0 3.8-1.2t2.7-3.4 0.9-4.8q0-2-1.1-3.8t-3.1-2.9-4.5-1.2q-1.9 0-3.5 0.5t-2.8 1.4-2 2-1.2 2.3-0.4 2.4q0 1.9 0.7 3.3t2.1 2q0.5 0.2 0.7-0.4 0-0.1 0.1-0.5t0.2-0.5q0.1-0.4-0.2-0.8-0.9-1.1-0.9-2.7 0-2.7 1.9-4.6t4.9-2q2.7 0 4.2 1.5t1.5 3.8q0 3-1.2 5.2t-3.1 2.1q-1.1 0-1.7-0.8t-0.4-1.9q0.1-0.6 0.5-1.7t0.5-1.8 0.2-1.4q0-0.9-0.5-1.5t-1.4-0.6q-1.1 0-1.9 1t-0.8 2.6q0 1.3 0.4 2.2l-1.8 7.5q-0.3 1.2-0.2 3.2-3.7-1.6-6-5t-2.3-7.6q0-3.7 1.9-6.9t5-5 6.9-1.9 6.9 1.9 5 5 1.8 6.9z"/></svg></span></a></li><li class="shariff-button odnoklassniki" style="background-color:#dd4814;border-radius:10%"><a href="https://connect.ok.ru/offer?url=http%3A%2F%2Fgeekus.ru&title=%D0%93%D0%B8%D0%BA%D0%BE%D0%B2%D1%81%D0%BA%D0%B8%D0%B9%20%D0%B1%D0%BB%D0%BE%D0%B3%20Geekus.ru" title="Поделиться на Odnoklassniki" aria-label="Поделиться на Odnoklassniki" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg xmlns="http://www.w3.org/2000/svg" width="14" height="20" viewBox="0 0 14 20"><path fill="#ee8208"  d="M7.1 10.1q-2.1 0-3.6-1.5t-1.5-3.6q0-2.1 1.5-3.6t3.6-1.5 3.6 1.5 1.5 3.6q0 2.1-1.5 3.6t-3.6 1.5zM7.1 2.6q-1 0-1.8 0.7t-0.7 1.8q0 1 0.7 1.8t1.8 0.7 1.8-0.7 0.7-1.8q0-1-0.7-1.8t-1.8-0.7zM13 10.7q0.1 0.3 0.2 0.6t0 0.5-0.3 0.4-0.5 0.4-0.7 0.5q-1.3 0.8-3.5 1l0.8 0.8 3 3q0.3 0.3 0.3 0.8t-0.3 0.8l-0.1 0.1q-0.3 0.3-0.8 0.3t-0.8-0.3q-0.7-0.8-3-3l-3 3q-0.3 0.3-0.8 0.3t-0.8-0.3l-0.1-0.1q-0.3-0.3-0.3-0.8t0.3-0.8l3.8-3.8q-2.3-0.2-3.5-1-0.4-0.3-0.7-0.5t-0.5-0.4-0.3-0.4 0-0.5 0.2-0.6q0.1-0.2 0.3-0.4t0.5-0.2 0.6 0 0.7 0.4q0.1 0 0.2 0.1t0.5 0.3 0.8 0.3 1 0.3 1.3 0.1q1 0 1.9-0.3t1.3-0.6l0.4-0.3q0.4-0.3 0.7-0.4t0.6 0 0.5 0.2 0.3 0.4z"/></svg></span></a></li><li class="shariff-button vk" style="background-color:#dd4814;border-radius:10%"><a href="https://vk.com/share.php?url=http%3A%2F%2Fgeekus.ru" title="Поделиться на ВКонтакте" aria-label="Поделиться на ВКонтакте" role="button" rel="noopener nofollow" class="shariff-link" style=";border-radius:10%; background-color:#999; color:#fff" target="_blank"><span class="shariff-icon" style=""><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 34 32"><path fill="#527498" d="M34.2 9.3q0.4 1.1-2.7 5.3-0.4 0.6-1.2 1.5-1.4 1.8-1.6 2.3-0.3 0.7 0.3 1.4 0.3 0.4 1.4 1.5h0l0.1 0.1q2.5 2.3 3.4 3.9 0.1 0.1 0.1 0.2t0.1 0.5 0 0.6-0.4 0.5-1.1 0.2l-4.6 0.1q-0.4 0.1-1-0.1t-0.9-0.4l-0.4-0.2q-0.5-0.4-1.2-1.1t-1.2-1.4-1.1-1-1-0.3q-0.1 0-0.1 0.1t-0.3 0.3-0.4 0.5-0.3 0.9-0.1 1.4q0 0.3-0.1 0.5t-0.1 0.3l-0.1 0.1q-0.3 0.3-0.9 0.4h-2.1q-1.3 0.1-2.6-0.3t-2.3-0.9-1.8-1.2-1.3-1l-0.4-0.4q-0.2-0.2-0.5-0.5t-1.3-1.6-1.9-2.7-2.2-3.8-2.3-4.9q-0.1-0.3-0.1-0.5t0.1-0.3l0.1-0.1q0.3-0.3 1-0.3l4.9 0q0.2 0 0.4 0.1t0.3 0.2l0.1 0.1q0.3 0.2 0.4 0.6 0.4 0.9 0.8 1.8t0.7 1.5l0.3 0.5q0.5 1.1 1 1.9t0.9 1.2 0.7 0.7 0.6 0.3 0.5-0.1q0 0 0.1-0.1t0.2-0.4 0.2-0.8 0.2-1.4 0-2.2q0-0.7-0.2-1.3t-0.2-0.8l-0.1-0.2q-0.4-0.6-1.5-0.8-0.2 0 0.1-0.4 0.3-0.3 0.7-0.5 0.9-0.5 4.3-0.4 1.5 0 2.4 0.2 0.4 0.1 0.6 0.2t0.4 0.4 0.2 0.6 0.1 0.8 0 1 0 1.3 0 1.5q0 0.2 0 0.8t0 0.9 0.1 0.7 0.2 0.7 0.4 0.4q0.1 0 0.3 0.1t0.5-0.2 0.7-0.6 0.9-1.2 1.2-1.9q1.1-1.9 1.9-4 0.1-0.2 0.2-0.3t0.2-0.2l0.1-0.1 0.1 0t0.2-0.1 0.4 0l5.1 0q0.7-0.1 1.1 0t0.6 0.3z"/></svg></span></a></li></ul></div></aside><aside class="widget_text well widget widget_custom_html"><h3><span class="glyphicon glyphicon-menu-right" aria-hidden="true"></span>&nbsp;Полезные сервисы</h3><div class="textwidget custom-html-widget"><div class="btn-group-vertical btn-group-sideblock"> <a href="/out/trello.php" class="btn btn-default btn-med" rel="noopener nofollow noreferrer" target="_blank"><img src="/media/w-logo-trello.png" alt="Trello" align="left"> Trello — универсальный сервис для планирования</a> <a href="/out/dropbox.php" class="btn btn-default btn-med" rel="noopener nofollow noreferrer" target="_blank"><img src="/media/w-logo-dropbox.png" alt="Dropbox" align="left"> Dropbox — топовый сервис для облачного хранения данных</a> <a href="/out/payoneer.php" class="btn btn-default btn-med" rel="noopener nofollow noreferrer" target="_blank"><img src="/media/w-logo-payoneer.png" alt="Payoneer" align="left"> Payoneer — лучшая платежная система для фрилансеров</a> <a href="/out/reg-ru.php" class="btn btn-default btn-med" rel="noopener nofollow noreferrer" target="_blank"><img src="/media/w-logo-reg-ru.png" alt="Reg.Ru" align="left"> Reg.Ru — отличный регистратор, доступные цены</a> <a href="/out/timeweb.php" class="btn btn-default btn-med" rel="noopener nofollow noreferrer" target="_blank"><img src="/media/w-logo-timeweb.png" alt="TimeWeb" align="left"> TimeWeb — надежный хостер, пользуюсь и рекомендую</a></div></div></aside><aside class="widget_text well widget widget_custom_html"><h3><span class="glyphicon glyphicon-menu-right" aria-hidden="true"></span>&nbsp;Подписка на обновления</h3><div class="textwidget custom-html-widget">Вы можете <a href="https://www.facebook.com/groups/geekus.ru/" target="_blank" rel="noopener noreferrer">вступить в нашу группу в Facebook</a> и подписаться на обновления в <a href="https://twitter.com/geekus_ru" target="_blank" rel="noopener noreferrer">Twitter</a> или через <a href="/feed/" target="_blank" rel="noopener noreferrer">RSS</a>.</div></aside><aside class="widget_text well widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="alert alert-info" style="margin-bottom: 10px;">Нужны иллюстрации или анимации? <a href="http://zhart.us/contacts/">Обращайтесь</a>. Примеры работ — <a href="http://zhart.us/">в портфолио</a>.</div><div id="altcon1"></div><style type="text/css">.gks-all-sd-resp { width: 320px; margin: 10px auto; } @media (min-width: 320px) { .gks-all-sd-resp { width: 230px; } } @media (min-width: 480px) { .gks-all-sd-resp { width: 380px; } } @media (min-width: 768px) { .gks-all-sd-resp { width: 680px; } } @media (min-width: 992px) { .gks-all-sd-resp { width: 250px; } } @media (min-width: 1200px) { .gks-all-sd-resp { width: 300px; } }</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Gks_All_Sd_Resp --> <ins class="adsbygoogle gks-all-sd-resp"
style="display:block"
data-ad-client="ca-pub-5168781927663874"
data-ad-slot="1361408431"
data-ad-format="auto"></ins> <script>setTimeout(function(){(adsbygoogle = window.adsbygoogle || []).push({})}, 1000);</script></div></aside> <aside class="well widget widget_recent_entries"><h3><span class="glyphicon glyphicon-menu-right" aria-hidden="true"></span>&nbsp;Последние статьи</h3><ul><li> <a href="https://geekus.ru/linux-files-encryption/">Быстрое шифрование файлов в Linux и синхронизация их через Dropbox</a></li><li> <a href="https://geekus.ru/ubuntu-caps-lock-keyboard-layout-change/" aria-current="page">Переключение языковой раскладки по Caps Lock в новых версиях Ubuntu (18.04, 18.10, 19.04, 19.10&#8230;)</a></li><li> <a href="https://geekus.ru/albert-launcher/">Albert &#8211; отличный лаунчер для Ubuntu</a></li><li> <a href="https://geekus.ru/budgie-as-unity-replacement/">Budgie &#8211; достойная замена для Unity в Ubuntu</a></li><li> <a href="https://geekus.ru/youtube-converter/">Сохранение видео с YouTube на локальный компьютер</a></li><li> <a href="https://geekus.ru/spotify/">Как пользоваться Spotify в России и Украине</a></li><li> <a href="https://geekus.ru/linux-games-steam-top/">200 лучших игр для Linux в Steam</a></li><li> <a href="https://geekus.ru/imgur-screenshot/">Мгновенное создание скриншотов и отправка их на imgur</a></li><li> <a href="https://geekus.ru/fman/">Файловый менеджер fman — новая альтернатива среди двухпанельников</a></li><li> <a href="https://geekus.ru/steam-proton/">Запуск Win-игр под Linux в Steam Proton</a></li></ul></aside> </section></div><!-- End Col-md-4 --></div><!-- End row --></div> <!-- End container main --> <footer role="contentinfo" class="clearfix hidden-print"><div class="container"><div class="row"><div class="col-md-4"></div><div class="col-md-4"></div><div class="col-md-4"></div></div><div class="row"><div class="col-md-12 text-center"> &copy; 2020 Geekus</div></div></div> </footer><style id="fvm-footer-0" media="all">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</style><script type='text/javascript' id='fvm-footer-0-js-extra'>/*  */
var shield_comments = {"ajax":{"comment_token":{"action":"icwp-wpsf","exec":"comment_token107.23.218.4","exec_nonce":"5f3f656435","mod_slug":"icwp-wpsf-comments_filter","ajaxurl":"https:\/\/geekus.ru\/wp-admin\/admin-ajax.php","ts":1604653106,"post_id":689}},"vars":{"cbname":"cb_nombre1062981812","botts":1604653106,"token":"not created","uniq":"rRbMy9awWN6t25fYpZ3KmEK7","cooldown":30,"expires":1800},"strings":{"label":"\u042f \u043d\u0435 \u0441\u043f\u0430\u043c\u0435\u0440","alert":"\u041f\u043e\u0441\u0442\u0430\u0432\u044c\u0442\u0435 \u0433\u0430\u043b\u043e\u0447\u043a\u0443, \u0447\u0442\u043e\u0431\u044b \u043f\u043e\u0434\u0442\u0432\u0435\u0440\u0434\u0438\u0442\u044c, \u0447\u0442\u043e \u0432\u044b \u043d\u0435 \u0441\u043f\u0430\u043c\u0435\u0440","comment_reload":"\u041f\u0435\u0440\u0435\u0437\u0430\u0433\u0440\u0443\u0437\u0438\u0442\u0435 \u0441\u0442\u0440\u0430\u043d\u0438\u0446\u0443 \u0434\u043b\u044f \u043e\u0442\u043f\u0440\u0430\u0432\u043a\u0438 \u043a\u043e\u043c\u043c\u0435\u043d\u0442\u0430\u0440\u0438\u044f","js_comment_wait":"\u041f\u043e\u0436\u0430\u043b\u0443\u0439\u0441\u0442\u0430, \u043f\u043e\u0434\u043e\u0436\u0434\u0438\u0442\u0435 %s \u0441\u0435\u043a\u0443\u043d\u0434 \u043f\u0435\u0440\u0435\u0434 \u043e\u0442\u043f\u0440\u0430\u0432\u043a\u043e\u0439 \u043d\u043e\u0432\u043e\u0433\u043e \u043a\u043e\u043c\u043c\u0435\u043d\u0442\u0430\u0440\u0438\u044f"},"flags":{"gasp":true,"recap":false}};
/*  */</script> <script type='text/javascript' src='https://geekus.ru/media/cache/fvm/1601541565/out/footer-27366b8aff41306470fd1e3ea55eac46d8f8e85c.min.js' id='fvm-footer-0-js'></script> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script></body></html>